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FLIGHT RECORDER 1 (FR-1)- GPS LOGGER 
 

 

 

 

 

The Flight Recorder - 1 telemetry module is a high performance, GPS data logging system which enables local 

logging of GPS data via onboard Micro-SD storage, temperature, power, and ADC channel data are also logged in 

separate files. Add a 9V battery, SD-Card, connect antenna, and go! Full data logs available for import later via 

MicroSD. Also outputs NMEA data on CPU_TXD/CPU_RXD host interface and can be interfaced to BT/Wi-Fi/RF. 

 16MIPS RISC CPU for high-performance GPS system processing  

o Filtering for GPGGA/GPGSA to preserve RF Link bandwidth and real-time background processing 

o Output on CPU_TXD/CPU_RXD for interfacing to an external Modem 

 SDIO Micro-SD Memory Card support (J6) for  data logging  

o FAT16/FAT32 media (up to T10 V2.0 32GB Cards) 

 High-performance uBlox LEA-6 GPS Receiver Module with uBlox u-Center USB support 

 External SMA connector for active input GPS Receiver antenna 

o Sarantel SL1206R GeoHelix®-P2 high-performance, high-gain, low-noise amplified active input 

GPS receiver antenna (recommended) 
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 Up to 12V, 10A input power support 

 Temperature Sensing from -55°C to +125°C with 0.5°C Accuracy 

 Voltage Metering of Primary battery, Current, and GPS Almanac Battery 

 Supported software: any NMEA GPS Program (ExpertGPS, VisualGPS, Google Earth, etc) 

 3V External battery for GPS Almanac back up and uBlox-6 Hot-Start™ 

 

Mechanical 
Dimensions: 49.35mm W x 91.35mm L (1.94” W x3.59” L) 

PCB Mounting hole dimensions: 86.65mm x 43.65mm 

  

 J6: Micro-SD Slot: Any Micro-SD card formatted as either FAT16 or FAT32 media is supported.  

 J18: GPS Battery, attach GPS 3V Almanac battery to this connector. The connector is keyed for connection. 

 J2: uBlox uCenter USB Port 

 J11: RF Modem connection, RPSMA plug 

 J4: GPS Modem connection, SMA plug 

 J12: Power + Switch: Connective positive to +, negative to -, A/B to switch 

o To use without switch, either shunt A/B or connect positive(red) to B lead, and negative(black) to – lead. 

 

Configuration Jumper (CFG1/CFG2) 

 

- Default, Normally pins 11-12 are shorted (which runs GPS processing at boot). Note that this is the 6
th

 Jumper position 

from the edge of the board.  

NOTE: When this jumper is removed, the system allows for remote login and control (default password=rfs1) 
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NOTE: If this jumper is removed, your Base-station will NOT show any data on the display until the “gps” command is 

issued via the USB connection on the Basestation to the host computer. 

 

 

 

 

 

UART INTERFACE 
 

Pin-1 is the square hole, jumper goes 1-2,3-4,etc across. All IO is 3.3V logic levels. UART baud rate is fixed at 9600 

baud (9600, N, 8, 1).  

 

Jumper Pin Function  

J9 1 3V3_DC  

 2 CPU_TXD - console output (line based - \r\n) 

 4 CPU_RXD - console input (line based - \r\n) 

 

 

LEDS 

 
 D22: BPWR – glows red with Battery Power 

 D14: Activity – blinks green with RF Modem activity 

 D4: Fix – Glows Blue with GPS position 

 D3: Sys – Toggles with system activity 

 D29: SDIO – Toggles when writing data to SD-Card 

 

 

GPS Configuration 
 

Your GPS1 module comes with factory defaults. The uBlox GPS chipset also features a 2 week GPS Almanac 

(cache) which works in conjunction with the GPS almanac cache battery. The GPS Almanac aids navigation by 

providing for Ephemeris data at start-up and allows for a so-called “hot-start”. When the GPS module is powered 

down, the GPS Back-up battery keeps the Almanac up to date until the unit is powered back on again. If the GPS 

almanac is pre-programmed, initial lock times can take as long as 5 minutes while the uBlox chip-set downloads the 

GPS Almanac over the air (OTA). To accelerate start-up and provide a 2-week cache of data (with battery back-up), 

the following procedure is recommended for pre-flight configuration. 

 

1. Install uCenter (7.02) or later  

2. Connect the GPS battery to J18 
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3. Connect the main 9.6v battery or turn on the power switch connected to J12 

4. Connect a mini-USB cable to the GPS1 USB port and the other side to the computer 
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5. Start uCenter, select the “Receiver->Port->XXX” where XXX is the USB port found by your computer attached to GPS1. 

NOTE: you can use DeviceManager under Windows and find the uBlox USB Device port. 

 

6. NOTE: once uCenter is installed, the uBlox should be detected under Device Manager. To download the latest version 

of uCenter, visit http://www.u-blox.com/  

 

7. Select Configuration View as below 

http://www.u-blox.com/
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8. Verify that the configuration data will be saved to the device (BBR, FLASH, I2C EEPROM selected) 

 

9. Verify that NAV5 is set to Airborne Mode 
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Note that if the configuration is not set, uCenter will prompt to write back the data to the receiver.  Always answer Yes 

if you are sure of your configuration, if not, press “No” 

 

10. Verify the Rate is set to 2HZ (500msec) for 1-second real-time response with the Base station receiver 
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11. Select “Tools->AssistNow Offline” 
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12. Select 14 Days AlmanacPlus, and FLASH update 

 

 

The unit is now configured. Be sure to leave the GPS Battery connected to the module so that the GPS Almanac data 

is preserved up to and during flight. Should the GPS lose telemetry lock during flight, the GPS battery will ensure hot-

start and re-acquisition of fix in < 1 second with hot-start enabled. 



10 
REV B 03/27/14 

 

When completed, use the uCenter menu options: GPS Configuration -> (GPS->File) to save your GPS configuration. 

For fast recovery, use the GPS Configuration (File->GPS) option to program your receiver. Verify the firmware and 

uCenter version first before following this procedure (and note that newer versions of firmware require newer versions 

of uCenter for correct programming).  

Sample configuration files may also be found at http://www.realflightsystems.com/techpubs/ublox/  

 

TROUBLESHOOTING 
 

When powering up the board without using a switch, make sure you plug in the connector quickly to avoid transients. 

When powering up the boaord using a twist-wire switch, make sure you firmly press the two leads together first and 

then twist the wire (also to avoid transients). 

 

Note that when properly functioning, D29, SDIO will blink RED when writing data to SD-Card, if you do not see this 

behavior, power down the board, remove the SD-Card and re-insert it to make sure it is properly seated. 

 

Verify the jumper on CFG_1 is set - normally pins 11-12 are shorted (which runs GPS processing at boot). Note that 

this is the 6
th

 Jumper position from the edge of the board.  

 

NOTE: removing CFG_1 jumper pins 11-12 for Basestation-2 users will render their system inoperable until the 

jumper is re-inserted (in this mode, GPS-1 waits for remote login from the Basetation-1 forever). 

 

BATTERIES 
 

 DC voltage 6.0 - 14V DC (LD117STR, LM317) 

 Average current: 200-245ma 

Note that any battery 6V, 7V, 9V, 12V may be used. 

, select one with a current rating of 250mAh for one hour of use, higher mAh ratings for proportionally longer runtime 

(depending on battery type and chemistry).  

 

GPS OPERATIONAL LIMITS 
 

uBlox-6 Operational Limits under good GPS signal conditions and assuming Airborne platform configuration as 

documented. 

 Dynamics: ≤ 4 g 

 Altitude: 50,000 m (164,042 ft MSL) 

 Velocity: 500 m/s (1,118.47 MPH or 1640.42 feet/second, Mach 1.49) 

 
 

 

http://www.realflightsystems.com/techpubs/ublox/
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COMMAND INTERFACE 
 

When the configuration jumper on pins 11-12 is removed (the 6
th

 Jumper position from the edge of the board), and 

the CPU_TXD/CPU_RXD is connected to the host computer (3.3v level CMOS), the system will boot up and provide 

a remote control serial console. Following is the remote control console procedure using an FTDI 3.3v USB->Serial 

adapter cable connected to the UART pins. 

 

1. Connect the USB port of the Base station to the host PC. Windows will install drivers for the FTD232 serial device.  

2. For Windows, use any terminal emulation program you have installed (e.g. Hyperterminal), or use Putty (located on 

the CD).  Go to Device Manager and look under Com ports to find the name of the COM port to connect to.  Launch 

Putty, you will want to type the NAME of the Com-Port (e.g. COM23) into “serial line”, “9600” into speed, and type 

the name of the COM-Port (e.g. COM23) into the “Saved Sessions Field”. Press “Save”.  

 

 
3. Next, click on the Serial item on the list to the left titled “Category” 
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4. Confirm flow control off and 8,1,N serial settings. Note that the default settings for the Putty terminal emulation 

program have XON/XOFF selected! Keep in mind that if you use a new USB port on Windows, you may have to go 

through this process again (a well endowed desktop system may support dozens of USB ports). When satisfied with 

the new connection profile click on “Session” (under Category) to return to the previous menu. Press “Save”, then 

press “Open”.  

5. Now, the next time you run Putty you may load the configuration and just press “Open”. 

 

6. Now start putty and reboot the Base station (power cycle) 

7. Press enter when the prompt below is seen. NOTE: if the enter key is not pressed (e.g. you type nothing when the 

Base station boots), the USB connection acts as an NMEA output console allowing other programs (e.g. ExpertGPS) to 

perform real-time mapping of the data. 
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8. Boot the GPS-1 transmitter with the jumper removed. Note, one should be careful removing the 2MM jumper, it is 

not designed to be pried off. Use a small-tipped flat-head screw-driver and gently lift up on the bottom of the jumper.  

 
9. Login using the default password rfs1 - commands may now be issue to the Telemetry transmitter. 
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APPENDIX-1   FR-1  Commands 
 

gps – go into GPS mode, press “x” to exit 

adc – show adc 

stat – show statistics 

pass <password> - set the password 

hn <hostname> – set hostname of the system 

tz <offset> – set timezone offset (firmware versions 1.01 and later) 

e.g. “tz +8” will set to PST time. (NOTE: use “save” command to make persist 

across reboots) 

tm X – telemetry output mode 0=NMEA0183 1=hostname,NMEA0183 

e.g. “tm +1” will output “hostname,$GPGG..” etc – useful for multiple nodes on 

the same channel/link 

save – save configuration 

restore – restore defaults 

reboot – reboot the system 

 

Opening NMEA Data Files with Google Earth 
1) GPS Log files are stored as gpslogXX.log resulting in up to 100 files being named gpslog00.log to gpslog99.log. The 

date and time stamp of the file is updated every time the file is updated with GPS data. Note that the timestamps are 

stored in GMT time (which is GPS native time) by default. Basestation-1 users may change the timezone for localtime 

2) Launch Google Earth, the version used is as shown (6.2.2.6613) 

Check Version 
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File->Open 
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Select “All Files” 

 

Double click on the NMEA data file (gpslogXX.log (where XX=0-99). A Dialog is presented to show options for the 

NMEA data-file import. 

Select Import Options 

 

The above dialog is display, Select “Create KML Tracks”, deselect other options.The file is opened and the Globe will 

move to the tracks just imported. 
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Move to Location 

 

Double clock on the GPS Device, then click on the Tracks, and then the Arrow symbol entitled “No Name”. Google 

Earth will Zoom in on the area of interest, you can move the Google earth knobs to get a better view of the data. 
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Reposition View 

 

 

  



19 
REV B 03/27/14 

 

Save GPS Track as KMZ File 
Right click on the GPS Device and select “Save Place as” 
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Elevation Profile. 
To show the Elevation Profile, right click on the tracks as below: 
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Importing Sensor Data into Microsoft Excel 
1) Launch Microsoft Excel, File->Open, All Files Selected 

 

Import Wizard Page one 

 

Select Delimited File, Press Next 
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Wizard Page Two: Select Delimiters 

 

Select Tab, Comma, Space,  and option “Treat consecutive delimiters as one”, “Text pattern” is “*”, press 

Finish” 

Data Imported 

 

Insert Row for Labels, press “ALT+i+r” to insert a row with the cell cursor centered at 1A, the labels are as 

below: 
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Tag,Seconds,Main Batt,GPS Batt,Main Current,User Current,V1 Volts,V2 Volts,U1 Volts,U2 Volts,Temp 

(F),Temp ( C),LRC 

Plot main Battery Voltage 
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Select all Main Batt cells, press Insert->Chart,etc. 

Plot Main Battery Current 

 

 

Select the Main current column, select Insert, Chart->3DLine and notice the plot.  
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Plot Temperature 

 

Select the Temperature (F) row (all cells). Select the Insert 3D Line chart option. 

 



26 
REV B 03/27/14 

 

Total Time running 

 

 

Select the last row of seconds data, divide by 60 for minutes, divide that result by 60 for hours. 

 

 

 

 


