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GPS-1 

 

 

The GPS-1 telemetry module is a high performance, secure, tracking, monitoring, and data logging system which 

enables tranmission of GPS position and telemetry data up to 100 miles LOS (Line of sight) to the Base-station-1 or 

Base-station-2 receiver. It also features local logging of all sensor and GPS data onboard Micro-SD storage..  

 16MIPS RISC CPU for high-performance GPS system processing  

o Filtering for GPGGA/GPGSA to preserve RF Link bandwidth and real-time background processing 

 SDIO Micro-SD Memory Card support (J6) for  data logging  

o FAT16/FAT32 media (up to T10 V2.0 32GB Cards) 

 High-performance uBlox LEA-6 GPS Receiver Module with uBlox u-Center USB support 

 30dbM (1Watt) 900Mhz Frequency Hopping Spread Spectrum Transceiver supporting up to 500Kbps data rate 

o Up to 16 independent channels operate concurrently 

o AES Encryption for link security 

o Requires no field configuration/provisioning or HAM Radio License  

o FCC and Canadian IC Certified for Unlicensed Operation 

 External SMA connector for active input GPS Receiver antenna 

o Sarantel SL1206R GeoHelix®-P2 high-performance, high-gain, low-noise amplified active input 

GPS receiver antenna (recommended) 

 Up to 12V, 10A input power support 

 Temperature Sensing from -55°C to +125°C with 0.5°C Accuracy 

 Voltage Metering of Primary battery, Current, and GPS Almanac Battery 
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 Supported software: any NMEA GPS Program (ExpertGPS, VisualGPS, Google Earth, etc) 

 3V External battery for GPS Almanac back up and uBlox-6 Hot-Start™ 

 Over 9hrs operational time (running all features) using 9.6V 2200mah NiMh 8xAA battery pack 

Accessories 
 Sarantel SL1206R GeoHelix®-P2 high-performance, high-gain, low-noise amplified active input GPS antenna 

 0dBi RF Antenna + low-loss RG174 RPSMA extension cable 

 Deans Male plug 

 Micro-SD Card  

 External 3V GPS Battery with JTEK connector 

 

Mechanical 
Dimensions: 49.35mm W x 91.35mm L (1.94” W x3.59” L) 

PCB Mounting hole dimensions: 86.65mm x 43.65mm 

  

 J6: Micro-SD Slot: Any Micro-SD card formatted as either FAT16 or FAT32 media is supported.  

 J18: GPS Battery, attach GPS 3V Almanac battery to this connector. The connector is keyed for connection. 

 J2: uBlox uCenter USB Port 

 J11: RF Modem connection, RPSMA plug 

 J4: GPS Modem connection, SMA plug 

 J12: Power + Switch: Connective positive to +, negative to -, A/B to switch, to use without switch, either shunt A/B or 

connect positive to B lead, and negative to – lead. 
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Configuration Jumper (CFG1/CFG2) 

 

- Default, Normally pins 11-12 are shorted (which runs GPS processing at boot). Note that this is the 6
th

 Jumper position 

from the edge of the board.  

NOTE: When this jumper is removed, the system allows for remote login and control (default password=rfs1) 

NOTE: If this jumper is removed, your Base-station will NOT show any data on the display until the “gps” command is 

issued via the USB connection on the Basestation to the host computer. 

 

 

 

 

 

LEDS 

 
 D22: BPWR – glows red with Battery Power 

 D14: Activity – blinks green with RF Modem activity 

 D4: Fix – Glows Blue with GPS position 

 D3: Sys – Toggles with system activity 

 D29: SDIO – Toggles when writing data to SD-Card 

 

Configuration and Pre-Flight 
 

1. Attach RPSMA Modem Antenna 

2. Attach SMA GPS Antenna 

3. Attach J18 GPS Battery 

4. Download GPS Almanac to the device, connect J2 Mini-USB to host Computer and use uCenter 

5. Verify CFG_1 Jumper pins 11-12 are shorted (this is the 6
th

 position from the far left of the pin header) 

6. Connect Power, and optionally, power switch 

7. Verify a fresh FAT32 or FAT16 formatted SD-Card is installed in J6, Micro-SD Slot 

8. Wait for GPS Lock LED and airplane symbol on receiver 
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Mounting GPS-1 
GPS1 requires a firm mounting in order to operate properly, mechanical vibrations may reduce performance and can 

damage your system if it is not mounted securely. It is best to mount the unit using stand-offs and 4-40 mounting 

bolts.  

 

 

GPS PRE-FLIGHT Configuration 
 

Your GPS1 module comes pre-configured for Aircraft mode GPS telemetry. The uBlox GPS chipset also features a 2 

week GPS Almanac (cache) which works in conjunction with the GPS almanac cache battery. The GPS Almanac 

aids navigation by providing for Ephemeris data at start-up and allows for a so-called “hot-start”. When the GPS 

module is powered down, the GPS Back-up battery keeps the Almanac up to date until the unit is powered back on 

again. If the GPS almanac is pre-programmed, initial lock times can take as long as 5 minutes while the uBlox chip-
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set downloads the GPS Almanac over the air (OTA). To accelerate start-up and provide a 2-week cache of data (with 

battery back-up), the following procedure is recommended for pre-flight configuration. 

 

1. Install uCenter (6.20) or later as located on the CD-ROM 

2. Connect the GPS battery to J18 

 

3. Connect a mini-USB cable to the GPS1 USB port and the other side to the computer 
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4. Start uCenter, select the “Receiver->Port->XXX” where XXX is the USB port found by your computer attached to GPS1. 

NOTE: you can use DeviceManager under Windows and find the uBlox USB Device port. 

 

 

 

5. Select Configuration View as below 
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6. Verify that the configuration data will be saved to the device (BBR, FLASH, I2C EEPROM selected) 

 

7. Verify that NAV5 is set to Airborne Mode 
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Note that if the configuration is not set, uCenter will prompt to write back the data to the receiver.  Always answer Yes 

if you are sure of your configuration, if not, press “No” 

 

8. Verify the Rate is set to 2HZ (500msec) for 1-second real-time response with the Base station receiver 
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9. Select “Tools->AssistNow Offline” 
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10. Select 14 Days AlmanacPlus, and FLASH update 

 

 

The unit is now configured. Be sure to leave the GPS Battery connected to the module so that the GPS Almanac data 

is preserved up to and during flight. Should the GPS lose telemetry lock during flight, the GPS battery will ensure hot-

start and re-acquisition of fix in < 1 second with hot-start enabled. 
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Should your unit become accidentally reconfigured mis-configured, please visit the website 

http://www.realflightsystems.com/ for the latest uBlox configuration file.  

APPENDIX-1  GPS-1  Remote Shell 
 

When the configuration jumper on pins 11-12 is removed (the 6
th

 Jumper position from the edge of the board), and 

the Base-station is connected to the host computer USB port, the system will boot up and provide a remote control 

serial console (like the remote control console on the GPS-2). Following is the remote control console procedure. 

 

1. Connect the USB port of the Base station to the host PC. Windows will install drivers for the FTD232 serial device.  

2. For Windows, use any terminal emulation program you have installed (e.g. Hyperterminal), or use Putty (located on 

the CD).  Go to Device Manager and look under Com ports to find the name of the COM port to connect to.  Launch 

Putty, you will want to type the NAME of the Com-Port (e.g. COM23) into “serial line”, “9600” into speed, and type 

the name of the COM-Port (e.g. COM23) into the “Saved Sessions Field”. Press “Save”.  

 

 
3. Next, click on the Serial item on the list to the left titled “Category” 

http://www.realflightsystems.com/
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4. Confirm flow control off and 8,1,N serial settings. Keep in mind that if you use a new USB port on Windows, you may 

have to go through this process again (a well endowed desktop system may support dozens of USB ports). When 

satisfied with the new connection profile click on “Session” (under Category) to return to the previous menu. Press 

“Save”, then press “Open”.  

5. Now, the next time you run Putty you may load the configuration and just press “Open”. 

 

6. Now start putty and reboot the Base station (power cycle) 

7. Press enter when the prompt below is seen. NOTE: if the enter key is not pressed (e.g. you type nothing when the 

Base station boots), the USB connection acts as an NMEA output console allowing other programs (e.g. ExpertGPS) to 

perform real-time mapping of the data. 
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8. Boot the GPS-1 transmitter with the jumper removed. Note, one should be careful removing the 2MM jumper, it is 

not designed to be pried off. Use a small-tipped flat-head screw-driver and gently lift up on the bottom of the jumper.  

 
9. Login using the default password rfs1 - commands may now be issue to the Telemetry transmitter. 
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APPENDIX-2 GPS-1  Command reference 
 

gps – go into GPS mode, press “x” to exit 

adc – show adc 

stat – show statistics 

restore – restore defaults 

save – save configuration 

pass <password> - set the password 

reboot – reboot the system 

tz <offset> – set timezone offset (firmware versions 1.01 and later) 

e.g. “tz +8” will set to PST time. (NOTE: use “save” command to make persist 

across reboots) 

 

 

 

Pre-FLIGHT 

 
 Charge all batteries, they should be about 11V or more when fully charged.  

o The systems will shut down when the battery voltage reaches 5.36v, this is nominally 3-4hrs later on 

the base-station and 8hrs on the remote (2500ma battery on remote).  

o At 6 volts, a warning will appear on the base-station. 

 

 Install GPS Battery 

 

 Load the GPS Almanac – use uCenter (on the CDROM) and select “14 Day Almanac Plus” 

 

 Verify Lock sequence where you have multiple (> 4 total) satellites, a flashing airplane, and altitude. 

 

 Freshly format SD Card, install into SD-Card 

 

 Check Connections to battery and optional switch. 

 

POST-FLIGHT 
 Power off 

 NOTE: on older firmware versions (green board) 

o Immediately remove SD-Card, do not re-insert, it will overwrite your files! 
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 On newer firmware versions (blue board and version 1.01 and later) 

o A new data-file is created (up to 100 datafiles). After 100 data-files the first file is perpetually overwritten. 

o All files are written with their appropriate time-stamp (GMT + TZ-Offset) 

o See also the “tz” timezone command. 
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FIRMWARE HISTORY 

The log below describes changes in each GPS-1 firmware release.  

1.00 –07/12/12 Initial firmware for revision A/B PCB’s  

1.01 –12/29/12 Flight testing on over 14 flights, update time of day and system clock from GPRMC when data is known, add 

support for timezone offset (for localtime). Update time of day on files using localtime (GMT by default). Update logger 

subsystem to create a new file every time the system is booted. Up to 100 unique sequentially numbered files are 

supported, afterwards the initial files is perpetually overwritten. The new datafiles are “gpslogXY.log” and “syslogXY.csv” 

where XY increment on every file. 

 

 

Opening NMEA Data Files with Google Earth 
1) Rename the NMEA log file gpstrack.nme to gpstrack.nmea 

2) Launch Google Earth, the version used is as shown (6.2.2.6613) 

Check Version 
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File->Open 

 

 

 

Select “All Files” 

 

Double click on the NMEA data file (gpstrack.nmea). A Dialog is presented to show options for the NMEA data-file 

import. 
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Select Import Options 

 

The above dialog is display, Select “Create KML Tracks”, deselect other options.The file is opened and the Globe will 

move to the tracks just imported. 

Move to Location 

 

Double clock on the GPS Device, then click on the Tracks, and then the Arrow symbol entitled “No Name”. Google 

Earth will Zoom in on the area of interest, you can move the Google earth knobs to get a better view of the data. 
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Reposition View 
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Save GPS Track as KMZ File 
Right click on the GPS Device and select “Save Place as” 
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Elevation Profile 
To show the Elevation Profile, right click on the tracks as below: 
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Importing Sensor Data into Microsoft Excel 
1) Launch Microsoft Excel, File->Open, All Files Selected 

 

Import Wizard Page one 

 

Select Delimited File, Press Next 
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Wizard Page Two: Select Delimiters 

 

Select Tab, Comma, Space,  and option “Treat consecutive delimiters as one”, “Text pattern” is “*”, press 

Finish” 

Data Imported 

 

Insert Row for Labels, press “ALT+i+r” to insert a row with the cell cursor centered at 1A, the labels are as 

below: 
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Tag,Seconds,Main Batt,GPS Batt,Main Current,User Current,V1 Volts,V2 Volts,U1 Volts,U2 Volts,Temp 

(F),Temp ( C),LRC 

Plot main Battery Voltage 
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Select all Main Batt cells, press Insert->Chart,etc. 

Plot Main Battery Current 

 

 

Select the Main current column, select Insert, Chart->3DLine and notice the plot.  
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Plot Temperature 

 

Select the Temperature (F) row (all cells). Select the Insert 3D Line chart option. 
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Total Time running 

 

 

Select the last row of seconds data, divide by 60 for minutes, divide that result by 60 for hours. 
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WARNING: All liability waived. Rocketry is an inherently dangerous undertaking. Make your choices 

and take personal responsibility for the outcome of your endeavors, protect your privilege to fly 

rockets by not making the headlines or becoming a statistic. 

 

 

http://www.hse.gov.uk/workplacetransport/images/warning-general-2.gif

